a3 Lazy Load升级过后出错解决 - 51ste软件测试部落-中国软件测试者的乐园
登录|注册

a3 Lazy Load升级过后出错解决

楼主 ruink发布于:2018/03/01

Parse error: syntax error, unexpected ‘.’, expecting ‘,’ or ‘;’ in ~/wp-content/plugins/a3-lazy-load/admin/admin-ui.php on line 37

解决:经过查看wordpress该插件首页,明确说明新版本不再支持php5.5及以前版本。我试验后的结果,php升级到5.6版本后,可正常启用。当然最终笔者一步到位,把PHP升级到了7.0版本。

具体官方插件作者问题说明:

Hello @jayo, @stipe, @a9un9hari

Have checked and see the error that you are having is an incompatibility with PHP version 5.5.

PHP stopped support for 5.5 in July 2016 and strongly recommend that it is not used due to security vulnerabilities – see here
http://php.net/eol.php

WordPress Requirements state that to run WordPress system config should be
PHP version 7.2 or greater
MySQL version 5.6 or greater OR MariaDB version 10.0 or greater
HTTPS support

You can read more about that here https://wordpress.org/about/requirements/

There is a sample letter that you can use on that page to send to your host to upgrade your system. As soon as you upgrade to PHP 5.6 or higher you will not have the issue.

Regards
Steve

——该提问暂时没有回复!——

回复